Creating a “Must Use” plugin

Must Use plugins are plugins that are activated by default, and can’t be deactivated/deleted from /wp-admin/plugins.php

Creating an MU is pretty easy:

  1. create a folder called “mu-plugins” in /wp-content/



  2. create a php file inside of mu-plugins (call it whatever you like).
  3. Add functions to this file

Notes: mu plugins must be a single php file. You can’t drop a plugin directory in here and expect it to work. You can reference other files in subdirs in your mu-plugin, just make sure you’re using correct path structures so that it loads properly.

1 thought on “Creating a “Must Use” plugin”

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.